• Beta
Windows Support
  • 18 Nov 2020
  • 1 Minute To Read
  • Share
  • Dark
    Light

Windows Support

  • Share
  • Dark
    Light

The Ops CLI (v1.9.2 or later) is now shipping with limited Windows10 support. We consider our Windows support at an Alpha stage. Windows running docker can be configured a number of ways. We are currently supporting only one of those possible configurations.

Requirements:

  • Windows10 Pro or Enterprise
  • HyperV must be enabled on Windows10
  • Docker installation for Windows10 Pro or Enterprise
  • Latest version of NodeJS & NPM

Instructions:

  1. Install NodeJS: https://nodejs.org/en/download/
  2. Install Docker: https://hub.docker.com/editions/community/docker-ce-desktop-windows/
  3. Launch Windows PowerShell in 'Administrator' mode
  4. From within PowerShell run npm install -g "@cto.ai/ops" (version 1.9.2 or later)

This should fully install the CTO.ai CLI. If you encounter any issues please reach out and we'll be happy to help.

Was This Article Helpful?